[ZendTo] Re: IMAP authentication issue

Chris Barber chris at techquility.net
Mon May 9 17:17:31 BST 2011

> Unfortunately that's exactly the config that worked for me:

>  'authenticator' => 'IMAP',
>  'authIMAPServer' => 'imaphostname.dundee.ac.uk',
>  'authIMAPDomain' => 'dundee.ac.uk',

>For info, the ancient uw-imap version that we tested against was IMAP4rev1 v12.250, which is very old, but it just worked.

>Sorry I can't be of any further assistance, we are running with LDAP authentication now, although I did have to modify the zendto source to allow encrypted traffic to our >eDirectory tree ...

>Hope you get something sorted,

> Brian

I think I've narrowed the issue slightly but I still can't authenticate with IMAP. I see that Zendto is using the imap_open command in the code. I found that some people have had issues connecting to Zimbra's IMAP using imap_open. However, none of the workarounds I've seen help me. Most people fixed the issue by adding /novalidate-cert at the end of the IMAP server name. 

i.e.  'authIMAPServer' => 'mail.mydomain.com:993/ssl/novalidate-cert',

This didn't fix my issue. Besides, our Zimbra server currently also allows non ssl connections on the default port 143 and I am still getting username or password was incorrect in Zendto when I leave off the options and only specify the server name of mail.mydomain.com for authIMAPServer: 

i.e.  'authIMAPServer' => 'mail.mydomain.com',

Does anyone know if there is something I can tweak in Zimbra for this? The zendto code is likely clean so I don't really know if I should be looking there to add an option on the imap_open command maybe?


More information about the ZendTo mailing list