[ZendTo] Error when dropping off files in new clean install of ZendTo

Jules Field Jules at Zend.To
Wed Jun 26 09:08:10 BST 2019


It could well be an SELinux issue if you've been changing file 
attributes at all, or re-creating files (which some editors will do). As 
root, do
     restorecon -FRv /var/zendto /opt/zendto
then reboot your server. That restorecon command will forcibly apply the 
correct labels to all the files under those 2 directory trees. It will 
output the filename of every file it finds that it has the wrong labels. 
So its output may well be useful information for you.

If that doesn't resolve the issue, force a complete relabel. Again, as 
root, do
     touch /.autorelabel
then reboot your server. That boot will take some time as it will 
reapply the SELinux labels to your entire filesystem.

If that still doesn't resolve the issue, then...
Sort the /var/log/httpd by date ("ls -altr" will list the most recently 
modified files last) and have a look at the most recently modified error 
logfile. You should find a PHP error in there.

Please note: the apache user should *not* have a login shell, that's a 
huge security hole.
     chsh -s /sbin/nologin apache
will change it back.

Hope that helps,

On 25/06/2019 21:17, Karl Bundy via ZendTo wrote:
> Hello All,
> I am trying to do a fresh install of the latest ZendTo (version 5.19) on CentOS 7.  The install went fine with only one minor issue with the HTTPD config files missing the ServerName name value.  The web interface now pulls up fine, and I am able to login.  My next issue is that when I go to do a drop-off, I get the error "Sorry, I failed to drop-off your files!  Note that you cannon drop-off directories, only files".
> I did a search through the archives, and there was someone last year who had a similar problem, and I have tried the suggestions there.  I have tried disabling SElinux, and I have verified that the apache user has read and write access to the /var/zento directory (and sub directories).  I have set the apache user to have /bin/sh as the shell, and have su'd to the apache user and was able to create and delete files in the /var/zento/incoming and /var/zendto/dropoffs directory.  I have checked the /var/zendto/zendto.log file, and there is only one entry that the initial setup of database completed.  I don't see anything of note in the /var/log/messages or /var/log/httpd/zendto.error logs.
> Any suggestions on what to try next would be greatly appreciated.
> Thank you,
> Karl Bundy
> _______________________________________________
> ZendTo mailing list
> ZendTo at zend.to
> http://jul.es/mailman/listinfo/zendto



'Making machines do what you want requires only two qualities:
  1) Being slightly more stubborn that the computer, &
  2) Remembering that computers are electrified rocks.' - @JediJeremy

Twitter: @JulesFM

More information about the ZendTo mailing list