[ZendTo] Zend.to error during drop-off

Jules Field Jules at Zend.To
Thu Oct 25 15:48:46 BST 2018


As it doesn't appear to be a RAM problem, the beta won't help you anyway.

How did you upgrade from 4.x to 5.15 ?
The safest, quickest and easiest way is to start again with a new 
server/VM. Set it all up with my Installer, get everything working, then 
port across your database and drop-offs (if you want to).

To see exactly why this might be failing, check the ZendTo log (either 
in /var/zendto/zendto.log or else /var/log/zendto/zendto.log).
And then check your web server error logs (either in /var/log/httpd or 
/var/log/apache2 depending on what Linux variant you are using).

One of those logs should give some clues.

Let me know how you get on.


P.S. Sorry, yes, it wouldn't be NSSUtils.c as I wrote it in PHP. My bad. 
Long day. :(

On 25/10/2018 15:44, Ken Etter wrote:
> I don't see any instructions on the website for trying out the beta 
> version.  Not sure how to do that.
> Ken
> >>> Ken Etter 10/25/2018 10:28 AM >>>
> Jules,
> Thanks for the quick reply.
> /opt/zendto/lib/NSSUtils.c does not exist.
> /opt/zendto/lib/NSSUtils.php does exist.  So I edited that and 
> restarted apache.  No change - still get the error.
> # free -m
>               total        used        free      shared buff/cache   
> available
> Mem:           2000         673         833 10         492        1158
> Swap:          2047           0        2047
> Doesn't look like a memory issue.  Thoughts?
> Ken
> >>> Jules Field <Jules at Zend.To> 10/25/2018 10:17 AM >>>
> > Ken,
> The problem here appears to be the encryption using massive amounts of 
> RAM to generate the actual encryption key from the passphrase you type in.
> If you upgrade to the latest beta, I have tweaked the encryption so it 
> uses a lot less RAM.
> Otherwise, do a "free -m" or look at the output of "top" to see what 
> memory is in use.
> If you want to just edit the code for the memory reduction tweak, look 
> in /opt/zendto/lib/NSSUtils.c. In there, you will find 2 occurrences 
> of "MODERATE" (in caps). Change those to "INTERACTIVE" and then 
> restart Apache.
> That will tell you very quickly if it's the RAM problem.
> Cheers,
> Jules.
> On 25/10/2018 13:38, Ken Etter via ZendTo wrote:
>> I am running this on Ubuntu 16.04.5 LTS if that matters.
>> Ken
>> >>> Ken Etter via ZendTo <zendto at zend.to> 10/25/2018 8:36 AM >>>
>> Just upgraded my Zend.To installation from 4.x to 5.15-1. Everything 
>> appeared to go ok. But when I click drop-off files, I get an error 
>> that states: "Sorry, I failed to drop-off your files! Note that you 
>> cannot drop-off directories, only files." I'm not dropping off a 
>> directory, just a single file. I tried a couple different file types 
>> - same error each time. Any suggestions for fixing this? Thanks!
>> *Ken Etter*, System Administrator
>> Architectural Group
>> 260.432.9337|msktd.com <http://msktd.com/>
>> <http://msktd.com/>
>> _______________________________________________
>> ZendTo mailing list
>> ZendTo at zend.to
>> http://jul.es/mailman/listinfo/zendto
> Jules
> -- 
> The current UK shipping forecast:
> Shannon: Variable 3 or 4, becoming north 5 to 7, perhaps gale 8 later.
> Moderate, becoming rough or very rough. Rain then squally showers. Good,
> occasionally poor.
> www.Zend.To
> Twitter: @JulesFM



'If I were a Brazilian without land or money or the means to feed
  my children, I would be burning the rain forest too.' - Sting

Twitter: @JulesFM

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://jul.es/pipermail/zendto/attachments/20181025/c9ed747a/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: IMAGE.png
Type: image/png
Size: 10425 bytes
Desc: not available
URL: <http://jul.es/pipermail/zendto/attachments/20181025/c9ed747a/attachment-0001.png>

More information about the ZendTo mailing list