[ZendTo] Migration woes

Giddings, Bret bret at essex.ac.uk
Mon Apr 23 16:33:09 BST 2018

I eventually solved this problem. As part of the migration attempt, I had moved the original /var/zendto directory and created a new one. The new folder needed permissions tweaking to 0755 with owner root and group www-data to match those of the previous folder. It then worked fine.



From: Giddings, Bret
Sent: 18 April 2018 07:52
To: zendto at zend.to
Subject: Migration woes


I'm trying to do a migration from 3.71(!!) to the latest version. Using information at http://jul.es/pipermail/zendto/2014-February/002309.html, I have successfully been able to port the DB (sqlite2 to sqlite3) and dropped off files from the older server to a new one. This lets me pick up files that we're previously on the old server. However, when trying to drop off anything on the new server, I am getting an error of

Database Error

Database failure writing authentication key. Please notify the system administrator.

In the GUI and

Error: failed to add authdata for bret at essex.ac.uk to authtable

In the zendto.log. I've checked that the authtable structure is the same between versions and can insert the data that DBWriteAuthData attempts to write if I interact with the DB via the command line.

Have I missed anything?



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://jul.es/pipermail/zendto/attachments/20180423/6d1ea51f/attachment.html>

More information about the ZendTo mailing list